Z Offset Setting


#1

Is there a spot to enter a Z offset value in Vox?


#2

Hi @pyroclasmx, not sure to what you are referring to here, could you explain more?


#3

Think of it similar to babystepping. A way to pretell the gcode to start a little higher without extruding more filament to fill the new z height. It’s helpful with material like petg that needs the first layer printed a little higher to start.


#4

I am at my computer so here is an example of what I am doing manually in the gcode

;init bottom layer material
;new ratio
M567 P0 E1.00000:0.00000:0.00000:0.00000
;bottom layer
G1 X54.720 Y63.440 F5400.000
G1 Z0.4 ; <------ The initial layer height I have set is 0.35 for this print. I change it to Z0.4 so it’s a little higher off the build plate but the calculations for extrusion are still based off the 0.35 height. I am mainly just doing this on PETG for the initial layer and first layer depending on print. Helps me to prevent petg from sticking to the nozzle at start
G1 X56.640 Y62.000 F300.000 E0.48892
G1 X60.000 Y60.240 E1.26164


#5

Ok clear, we will discuss about it and in case we will add it.


#6

@pyroclasmx, you can achieve the same effect by reducing the “First layer extrusion” parameter like so:

image


#7

Hi there I’m trying to find the first layer settings in voxelizer and cant find them anywhere, I can’t even find a search bar to look for it? is it hidden somewhere or has it been removed?


#8

Hi @derdles, you need to select the second toolbar:


#9

I don’t have a quick settings menu in my voxelizer, i’m running 2.0.0 should it be present?


#10

No, in 2.0 there are no Quick Settings but you can find the parameter in the Filament settings (the second menu in your version). You will have to create a new preset if you want to change its value.
Most of the people here are using the Voxelizer 2.1 Experimental version by the way. Maybe you also want to give it a try :slight_smile: https://voxelizer.com/download


#11

awesome thanks for that I’ll have a look at 2.1


#12

Here as well, I’m currently Simplify 3D user and It has a way to offset the Z parameters, I couln’t find that in Voxelizer. My Printer start printing in the air. It doesn’t happen if the same file I export it and import it in simplify 3d and then generate the gcode from there.
any Ideas?


#13

Hi @djgabriel2004 at the moment we don’t have a Z offset parameter, anyway

are you sure that you don’t have a problem of Z axis calibration with your printer?


#14

It’s weird because It doesn’t happen the same way when Printing on Simplify.


#15

What printer are you using? Could you send me the gcode that you have problems with? Is Simplify set with the Z offset?