Voxelizer Experimental release notes 2018-11-16


#1

We’re continuing the (roughly) weekly schedule of Voxelizer Experimental updates.

The updates should automatically show up when starting Voxelizer - if they don’t, you can click on Help -> Check for updates.

Voxelizer Experimental release notes 2018-11-16

Features

  • it’s now possible to open .zip files containing 3d model files (also with textures), saving some clicks when downloading packed models from the internet (issue #205)
  • it’s now possible to merge aligned objects into one in scene editor (issue #204)
  • further support for textured files (issue #199)
  • small hanging objects are now automatically removed after some microstructures filters (issue #180)
  • the remove small objects filter now takes input in cubic millimeters instead of voxels (issue #210)
  • some more configuration for send to Octoprint - it’s now possible to choose the target between sdcard and local and possible to initiate print immediately after sending (issue #194)
  • last file open location on Windows is now remembered per-extension (issue #202)

Bug fixes

  • files passed as command-line arguments are now properly handled (issue #200 and #201, as reported by @dggrant here) - this also enables features such as Fusion 360’s send to 3d printing appliance to work with Voxelizer
  • it’s now possible to cancel surface error computations (issue #209)
  • fix for object too big persisting for the next model (issue #211, as mentioned by @friedokra here)
  • fix for negative values sometimes being generated in gcode
  • various other minor fixes

Using Win10 Send to
"object too big" message persists for next model
Showing Surface Error hangs the program
#2

I am having issues installing this update. After it goes to administrator mode, I get a message saying it cannot find the installation .msi file. I have tried to search for that file with no luck so I have to cancel the install.
Any help would be appreciated.
Doug G.


#3

It is looking for "the installation package 'voxelizer_installer_2.1.0- 2018-11-02 (1).msi update. Not the …2018-11-16.msi it should be looking for. At least I think this is the issue.
Doug G.


#4

Thanks for the report, could you try now? It might have been a cache of the update server, I’ve cleared it now.


#5

Same problem. It comes up after the administrator install button and the notice that it will have to reboot. Here is the message:
image

I tried going directly to the install …2018-11-16,msi file, but that does the same thing. It must be something in the installer itself that is looking for the wrong file. (At least that is my guess.)


#6

Unfortunately I’m unable to reproduce this problem for now.

Voxelizer downloads the .msi update package to the My Documents/Voxelizer2Experimental/update - can you check if the update package was downloaded there?

In case it still doesn’t work, please try the direct link for the most recent Experimental version: https://update.voxelizer.com/versions/experimental/latest/windows


#7

Yes, the 2018-11-16 package is there and I have tried to run it with the same results. I will try the direct link.
Thanks.


#8

Same results. I think I will try to uninstall the pervious version first and see if it will install then.
No one else has reported this? Strange.


#9

That didn’t work either. I had to revert to v2.1.0-2018-11-12. The install keeps looking for the wrong .msi file.
Doug


#10

I have tried shutting down my firewall and virus software and nothing changed it is still looking for the old version. I am done for this evening. Let me know if there I anything I can do from this end. (And if anyone else has the problem.) FYI, I am using the latest version of Win10.
Thanks, Doug


#11

I have done everything I can think of. I uninstalled McAfee. (I have had other issues with that in the past.) No matter what I do or where I load it from it looks for the old file. I know you probably won’t get to this until Monday, but I just wanted you to know what I have attempted. I have no other ideas everything seems to be working as it should but the install calls for a file that is not there. (Or anywhere else on my computer.)
Thanks,
Doug G.


#12

Doug did you try to uninstall Voxelizer, both the experimental and the official version and then install only the experimental from the direct link? Anyway we will investigate this issue.


#13

Alberto,
Yes, I did uninstall both. I looks to me like the installer is calling for the wrong program. It asks for the last version, …2018-11-02 (1).msi every time.
Doug


#14

Now I went through and deleted files and scanned the registry. I deleted everything Voxilizer related. I no longer have Voxilizer and cannot install it at all. --I still get the same message.
Doug


#15

If I click on “OK” on the “Accessing the feature…” pop up. I get the yellow triangle and the message about “The path…” If I click “OK” here I get a message saying it can’t uninstall the old version?? It sounds like maybe I need to install 2.1.0 before I can update?


#16

Doug, it looks like something got messed up a bit in your system, please try using this official Windows tool that is supposed to clean up situations like this (download it and select Voxelizer 2 Experimental from the list):
https://support.microsoft.com/en-us/help/17588/fix-problems-that-block-programs-from-being-installed-or-removed


#17

Woo Hoo! That worked! Thank you!

(I’ve been working with personal computers since the early eighties - and mainframe stuff before that - and this is the first time I have had this problem. The bonus - through the process I have really cleaned up my machine. :laughing: - I do wish I knew what MS corrected for future reference.)