Please do not add M84 to the end of a print


#1

Voxelizer is adding M84 to the end of all my prints, which on my Delta with a heavy Diamond Hotend causes the hot nozzle to plunge into the print.


#2

Doesn’t sound good… we will make the M84 optional.

By the way did you try the Diamond with Voxelizer? How did it go?


#3

In the next update you will find a new tool setting “Stop motors at end”. Add it and set it to false to disable the M84 command at the end of the gcode.


#4

It’s my first experience with a Delta printer so I’m still dialing things in, but the setup in Voxelizer for the Diamond was easy enough since I had already gone through the setup for an M3D Quad. The Diamond works great. I’ve not done a lot of color mixing just yet, but I’ll get there soon.

One suggestion, since there are other mixing extruders out there besides the Quad, you might consider changing the name of the Filament Switching setting to Mixing instead of M3D, or if it’s firmware specific then maybe change it to RepRap.


#5

Are you using the tricolor diamond or the full color (5 inputs)?

As far as the name goes The Crane Quad uses M567 which I believe is only for RepRap firmware (marlin and repetier use M163 and M164 I believe for mixing). So I believe an appropiate name instead of M3D would be “RepRap” or “RepRap mixing”.


#6

You are right guys, we are probably going to change the names.


#7

Tri-color Diamond. I’m not quite ready to dive into 5 colors just yet. :smiley: