Hello from M3D!


#7

Hi David,
I’m waiting for my Quad and I was looking at Voxeliser to see how to use it with the Quad - what I can’t find is whether it can use obj files with corresponding colour/texture info from a scan, photogrammetry or generated from a programme such as Daz3d to print full colour lifelike mannikin models.
Can you advise, please?
Harry


#8

Hi Harry, even though the question was not to me, I think I can answer. Voxelizer can read textures from obj files as well as PLY with vertex colors. You just have to import them in the scene and you should already see a preview of the model with the related colors.

Then, after voxelization, you just go to the Colors tab and drag and drop the Internal texture or Vertex color material (depending on the case) to the model.

The Texture wizard will open and you will be able to setup the material for gcode generation.

If you have questions, particularly regarding this last step, let me know.


#9

Hi Agiachino, thanks for your reply. I downloaded Voxelizer 2 however I’m not having much luck trying your ideas because when I try to run V2, it runs at a glacial speed. I have an AMD FX-3600 six core 3.50Ghz processor with 16Gb RAM, W7 64 bit - it should work quite fast, I thought. Any suggestions??
Cheers,
Harry


#10

Hi @harryn, which part exactly of the program is slow? Or everything, from the opening?


#11

Hi Agiachino,
The programme opens quickly, loads the file quickly then everything slows down. Even changing the filament from pla to abs can take 15-20 minutes with the programme heading telling me ‘Not responding’ half the time. Creating support, I left the computer running overnight since it didn’t achieve it after an hour… Now it’s telling me that the voxel object is overlapping with another object - there is only the obj file and it’s corresponding mtl file. I clicked 10 mins ago to ‘remove overlapping’ and the programme is ‘not responding’ but using 13Gb of memory.
Harry


#12

How many vertices/faces are we talking here? I mention that since you mention DAZ which are all very high poly. 3d printing can’t achieve anywhere near that level of detail so it’s always best to decimate your model quite a bit before import.


#13

@harryn, few more questions:

  • Did you use Voxelizer 2.0 or Voxelizer 2.1 (Experimental)? If you want to work with scans you should use the second one.
  • Did you pass the phase of voxelization?
  • Did you change the voxel size?
  • Did you use a photogrammetry model or a simple one? If you used a photogrammetry model, could you share it with us or send us a link, so that we can check it?

Thank you.

If he passed the phase of voxelization, this shouldn’t be an issue.


#14

I’ve been away from work for a few days so I couldn’t try these suggestions.

I used Voxelizer 2.
Previously, I’ve used Daz3d models exported as obj/mtl files and 3d printed the obj file directly using Simplify3d or passed them through Meshmixer to convert them to stl for printing with XYZware. No problems with vertices number with either programme.

I haven’t yet tried a photogrammetry created file.

Stages of Voxelizer 2: Opening programme - quick. Loading obj/mtl file - quick. Creating preview - quick but now using 9-10Gb RAM. Set support to ‘light’, slow to accept. Generating support - very slow, 14-15 Gb RAM used.

My computer has the following set up: AMD FX-6300 six core processor 3.50GHz, 16Gb RAM, W7 64 bit, NVidia GeForce GT730, all drivers uptodate, Open GL 4.6, Direct X 9 & 11.0

Will hopefully get a chance today of trying your suggestions but Mondays are always busy…

Cheers,

Harry


#15

I see, please try on the Experimental version, that’s the one we are developing and the one that most of the users on the forum are using.


#16

Thanks Agiachino,
I’ve loaded up the experimental version but according to the intro screen, I have no internet connection and it is not giving me a list of printers. I am connected but the programme obviously isn’t. Tried on another computer, same story.


Any suggestions, welcome.
Harry


#17

Hi Harry, sorry for late reply. Unfortunately you need to have an internet connection to start the program.


#18

Hi again,
I’ve just tried it on the laptop at home and it loads and gives me a choice of printer. Still tells me in red that I’m not connected so operating locally but a step forward anyway. Guess it has problems with the school network… I’ll have a chat with the school techie on Monday.
I tried a Daz3d obj/mtl file and it loaded OK but with out colour. Tried a Daz3d dae file which gave me colour on loading but as it processed, the model lost colour. Tried adding the textures but no further success. I’m maybe missing something so I’ll watch the videos again, read the notes… might find the answer somewhere.
Harry


#19

Hi @harryn, good that we are making some steps forward :slight_smile: Yes please check with the technician if you are operating on a network, there might be some blocks.
Regarding the model, could you share it here (or just with me privately, if you prefer) we will check it out.


#20

https://drive.google.com/file/d/1CVxEHW6-HQYwNgVxn_wgKnoG9PxwtzYU/view?usp=sharing
https://drive.google.com/file/d/1MRF-Vw8aaMn7KFOLFh41ZboVsS3jhH5j/view?usp=sharing

The obj and mtl of a quick test model - let me know if you want the dae file.
I’ll have a chat with the techie tomorrow.
Cheers,
Harry


#21

@harryn the file that you sent caught us a bit off guard, as it contains thousands of single meshes. At the moment Voxelizer is not designed to handle this type of situations. But thanks to your input we will try to improve it to cover more cases like yours. Yes please send also the dae so that we can see that one as well. We didn’t do many tests on this format, so there are probably parts than can need to be fixed.
In the meantime please try with this model and tell me if everything works fine (no need to unpack it): Sample_Ship_OBJ.zip (1.4 MB)


#22

Hi again.
I’ll send the other file when I get home.
Just trying the ship file and I can’t seem to make the colours fit to the final model

it opens with colour but it voxelises then has no colour. Adding the image and textures still doesn’t give me the full colour preview.
Had this same problem last night - what am I doing wrong? Something out of sequence perhaps? The online videos don’t seem to follow the experimental programme to well.
The programme at school, we sorted out; the programme couldn’t access the network so we set up a hot spot on the phone and connected via that and all well now.

Cheers,
Harry


#23

This is the expected behavior as the default option is still single color printing.

To get the closest possible match between the colors of the texture and the colors that you can get from your printer you need to click on the ‘Find key colors’ button. You can click it multiple times to get different combinations. If you are not satisfied with a particular color choice of the software, you can edit it by clicking on the color box or by manually editing the filament ratios.

Maybe you are already aware of the problem, anyway keep in mind that it is not possible to achieve all the colors from only four filaments. If your key color (the fourth one) is white, for instance, getting black is just impossible. That’s why the color wheel that we show has empty areas in it.

When moving towards gcode generation and printing, remember to check which ‘Generation mode’ works best for your model. In the case of this ship, for example, I believe is ‘Segmentation’. From the last release notes:

  • Weaving (the default) gives the previously available functionality, interweaving multiple outlines to achieve desired colors. This gives good results on vertical surfaces but doesn’t affect horizontal ones.
  • Segmentation splits the object into multiple objects based on the colors. This works for all surfaces but has more computational complexity and may lead to longer printing times.
  • Complex attempts to use Weaving for vertical surfaces and Segmentation for horizontal ones

#24

Thank you Agiachino, that will give me something to play with today. I’m hoping that M3D will come up with a 5 filament head sometime so we can have CYM + W + B and have better saturation and depth of colour.

A link to a file with obj, dae and fbx files of the same model from Daz3d for you to try
https://drive.google.com/drive/folders/1-IkwlCLk8ffAJCaD-qVt68jLLIvi2NYa?usp=sharing

Cheers,
Harry


#25

Hello again,
I’ve had fun playing with Voxelizer2 with new knowledge and I get the picture, colour has to be personally assigned to the parts of the print. What I was hoping for was that Voxeliser2 would take the mtl file and add it to the obj file in the correct places so that a fully coloured model as originally conceived was produced. I can’t seem to make that happen. I assume the XYZ da Vinci Color mini does apply the colour info file with the obj… to produce their prints. They look too complicated for that not to occur.
Cheers,
Harry


#26

Hi @harryn
in order to correctly load a textured obj file, the .obj, the .mtl and the texture image have to be in the same folder (which can also be a zipped one).

You then need to apply an Internal texture material to it.

See the attached example.

colorCube.zip (46.7 KB)